9 сент. 2016 г.

Проверить режим подключения к базе

Процедура КнопкаВыполнитьНажатие(Кнопка)
  Сообщить(РежимЗапуска(СтрокаСоединенияИнформационнойБазы()));
КонецПроцедуры
 
Функция РежимЗапуска(СтрокаСоединения)
 Если Найти(СтрокаСоединения,"File") <> 0 Тогда
  Возврат "Файловый";
 ИначеЕсли Найти(СтрокаСоединения,"Srvr") <> 0 Тогда 
  Возврат "Серверный";
 Иначе 
  Возврат "Неопределено";
 КонецЕсли;
КонецФункции
 

CopyPaste Copyright © 2017 - |- Шаблон создан O Pregador - |- Отредактирован myr4ik07