9 сент. 2016 г.

Выделить строку в списке Условное оформление

Выделяем в динамическом списке строку с условием
// кнопка на форме которая включает и выключает выделение в списке элементов 
&НаКлиенте
Процедура УО(Команда)
       
        ЭлементыУсловногоОформления = Список.КомпоновщикНастроек.ФиксированныеНастройки.УсловноеОформление.Элементы;
       
        ВыделитьДолжников = Неопределено;
        Для Каждого ЭлементОформления Из ЭлементыУсловногоОформления Цикл   
                //лучше всего искать УО по Представлению, а не по Отбору или Цвету
                Если ЭлементОформления.Представление = "Выделить дожлников" Тогда           
                        ВыделитьДолжников = ЭлементОформления;
                        Прервать;
                КонецЕсли;                           
        КонецЦикла;
       
        Если ВыделитьДолжников = Неопределено Тогда
                //не найшли УО, добавляем
                ВыделитьДолжников = ЭлементыУсловногоОформления.Добавить();
                ВыделитьДолжников.Оформление.УстановитьЗначениеПараметра("ЦветТекста",WebЦвета.Красный);
               
                ОтборДолг = ВыделитьДолжников.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
                ОтборДолг.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Долг");
                ОтборДолг.ВидСравнения = ВидСравненияКомпоновкиДанных.Больше;
                ОтборДолг.ПравоеЗначение = 0;
                ОтборДолг.Использование = Истина;
               
                ОформляемоеПоле = ВыделитьДолжников.Поля.Элементы.Добавить();
                ОформляемоеПоле.Поле = Новый ПолеКомпоновкиДанных("Наименование");
               
                ВыделитьДолжников.Представление = "Выделить дожлников"; // потом будет удобно по этому полю искать
                ВыделитьДолжников.Использование = Истина;               
        Иначе 
                //нашли, выключаем
                ВыделитьДолжников.Использование = Не ВыделитьДолжников.Использование; 
        КонецЕсли;
       
        //кнопку, если она нажата, выделим ее
        Элементы.УО.Пометка = ВыделитьДолжников.Использование;
                       
КонецПроцедуры
 

CopyPaste Copyright © 2017 - |- Шаблон создан O Pregador - |- Отредактирован myr4ik07