9 сент. 2016 г.

Извлечь двоичные данные с макета

В макет сохранил .msi инсталятор компоненты. По кнопке на форме нужно извлечь из макета .msi инсталятор и сохранить на hdd компютера. Компонента в макете под названием "mysqlconnectorodbc".
&НаКлиенте
Процедура ИзвлечьMSQLConnect(Команда)
        Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
       
        Диалог.Заголовок = "Выберите папку для сохранения";
        Диалог.Расширение = ".msi";
        Диалог.Фильтр = "(*.msi;*.msi|*.msi;*.msi|";
       
        Если Диалог.Выбрать() Тогда
                Извлечь(Диалог.ПолноеИмяФайла);
        КонецЕсли;   
КонецПроцедуры

Процедура Извлечь(ПолноеИмяФайла)
        РеквизитФормыВЗначение("Объект").ПолучитьМакет("mysqlconnectorodbc").Записать(ПолноеИмяФайла);
КонецПроцедуры
 

CopyPaste Copyright © 2017 - |- Шаблон создан O Pregador - |- Отредактирован myr4ik07