23 сент. 2016 г.

Неликвиды

В обработке есть возможность применять фильтры по: 
- складу 
- группе ТМЦ. 

А также можно сделать сортировку по колонке Стоимость. 

! Разрабатывалось для Бухгалтерия+Торговля+Производство+Зарплата+Кадры для Украины 



Неликвид рассчитывается так:
  • берем остатки на ТекущаяДата() – ВыбранноеКоличествоДней с Количеством больше 0;
  • ищем каждую ТМЦ из полученного выше результата в документах РасходнаяНакладная за период с ТекущаяДата() по ВыбранноеКоличествоДней;
  • в результирующий отчет вывожу только ту ТМЦ, которая за период в док.РасходнаяНакладная не попадалась

Нет возможности скачать? Пиши в комментариях адрес эл.почты - отправлю бесплатно.

20 сент. 2016 г.

Установить курсор на конкретную строку таблицы значений

Элементерно, но все же, например, нужно установить в Таблице значений управляемых формах курсор (активность) на последнюю строку

Элементы.СтрокиВыпускПродукции.ТекущаяСтрока =
ЭтаФорма.СтрокиВыпускПродукции.Получить(СтрокиВыпускПродукции.Количество()-1).ПолучитьИдентификатор();

19 сент. 2016 г.

Из Com объекта в таблицу значений

На вход передаем Com объект, на выходе будем иметь ТаблицуЗначений с наименованием колонок аналогично свойствам Com объекта + заполнена ТаблицаЗначений данными с Com объекта.
Функция ИзComВТаблицуЗначений(Com)
 //Перемещаем указатель на первую запись.
 Com.MoveFirst(); 
 
 Таблица = Новый ТаблицаЗначений; 
 ОдинРаз = Неопределено;
 
 //Начинаем перебор записей из субд
 Пока Com.EOF() = 0 Цикл
  
  //Заполним колонки
  Если ОдинРаз = Неопределено Тогда 
   Для Каждого Значение Из Com.Fields Цикл 
    Таблица.Колонки.Добавить(Значение.Name);
   КонецЦикла; 
   ОдинРаз = Истина;
  КонецЕсли;
  
  //Заполняем таблицу значений
  НовСтрока = Таблица.Добавить();
  Для Каждого Колонка Из Таблица.Колонки Цикл 
   Для Каждого Значение Из Com.Fields Цикл 
    Если Колонка.Имя = Значение.Name Тогда 
     НовСтрока[Колонка.Имя] = Значение.Value;
    КонецЕсли;    
   КонецЦикла;
  КонецЦикла;
  
  // Перемещаем указатель.
  Com.MoveNext();    
 КонецЦикла;    
 Возврат Таблица
КонецФункции

Очистка таблицы значений от ненужных строк

//Очистка ТЗ от ненужных строк, алгоритм Эльниньо

 ТЗ.ВыбратьСтроки();
 Пока ТЗ.ПолучитьСтроку() = 1 Цикл 
  
     Пока ТЗ.ЧтоТо = Ненужное Цикл
          ТЗ.УдалитьСтроку();
          Если ТЗ.НомерСтроки = 0 Тогда Прервать; КонецЕсли;
  КонецЦикла;

 КонецЦикла;

Правильное удаление строк из таблицы значений

//******************************************************************************
// ОчисткаТЗ()
// Параметры: ТЗ, которую надо очистить
// В ТЗ д.б. Колонки с идентификаторами "НадоУдалить" и "ОПС" (оригинальный порядок строк)
// Описание: очищает ТЗ от ненужных строк
Процедура глОчисткаТЗ(ТЗдляЧистки, ОПС="+ОПС", КолонкаУдалить="НадоУдалить", Режим=0) Экспорт
 
 Попытка  НадоУдалить = ТЗдляЧистки.Итог(КолонкаУдалить);
 Исключение Возврат;
 КонецПопытки;
 
 ТЗКС = ТЗдляЧистки.КоличествоСтрок();
 Если Режим <> 0 Тогда
  Сообщить("> ["+ТекущееВремя()+"]: *** удаляем "+НадоУдалить+" из "+ТЗКС+" ****"); 
 КонецЕсли;
 
 Если НадоУдалить <= 0 Тогда Возврат; КонецЕсли;
 
 Если НадоУдалить >= ТЗКС Тогда
  ТЗдляЧистки.УдалитьСтроки();
 Иначе
  ТЗРаб = СоздатьОбъект("ТаблицаЗначений"); ТЗдляЧистки.Выгрузить(ТЗРаб);
  ТЗРаб.Сортировать("+"+КолонкаУдалить); ТЗРаб.Выгрузить(ТЗдляЧистки,1,ТЗКС-НадоУдалить);
  ТЗРаб = 0;
 КонецЕсли;
 Если ПустаяСтрока(ОПС) = 1 Тогда Возврат; КонецЕсли; //сортировать не надо
 Если ОПС = "###" Тогда Возврат; КонецЕсли; //сортировать не надо
 //восстановим оригинальный порядок строк
 ТЗдляЧистки.Сортировать(ОПС);
КонецПроцедуры //глОчисткаТЗ()

Обмен сообщениями в 1С

При запуске 1С-ки в управляемом приложении подключается обработчик ожидания и обращается каждые 180 секунд к общему модулю, где в свою очередь идет обращение к функции, которая возвращает, есть ли для пользователя, который запустил 1С-ку сообщение, если сообщение есть, сообщения показывается на экран.

Отправка сообщения осуществляется с помощью обработки, в которой можно


  • выбрать одного или несколько получателей для отправки им сообщения (уведомления)
  • по кнопке "Открыть регистр сообщений" просмотреть сообщение которое будет отправлено для конкретного пользователя (пользователей)

-------------------------------------------------------------------------------------------------
!В конфигурации должен быть:
  • Справочник.Пользователи
  • ПараметрыСеанса.ТекушийПользователь
-------------------------------------------------------------------------------------------------

Для реализации обмена сообщениями в 1С в конфигурацию я добавил 

РегистрСведений СообщенияПользователям
Измерения: Пользователь = СправочникСсылка.Пользователи
Ресурс: Сообщение = Строка


Общий модуль РаботаСПользователем (Глобальный, Клиент (упр. приложение),Клиент (об. приложение))


где написал 
Процедура ПроцедураУведомленияПользователя() Экспорт
               СообщениеПользователю = Привилегированный.ПолучитьСообщенияДляКонкретногоПользователя();
               Если ЗначениеЗаполнено(СообщениеПользователю) Тогда
                               Привилегированный.УстановитьНовоеСообщениеДляПользователя("",Привилегированный.ПолучитьТекущегоПользователя());
                               Предупреждение(СообщениеПользователю,,"Внимание!");
               КонецЕсли;
КонецПроцедуры
Общий модуль Привилегированный (Сервер, Вызов из сервера, Привилегированный) 


где написал
Функция ПолучитьСообщенияДляКонкретногоПользователя() Экспорт
               ТекущийПользователь = Справочники.Пользователи.НайтиПоНаименованию(ПараметрыСеанса.ТекушийПользователь.Наименование,Истина);
              
               Запрос = Новый Запрос;
               Запрос.Текст =
                               "ВЫБРАТЬ
                               |              СообщенияПользователям.Сообщение
                               |ИЗ
                               |              РегистрСведений.СообщенияПользователям КАК СообщенияПользователям
                               |ГДЕ
                               |              СообщенияПользователям.Пользователь = &Пользователь";
              
               Запрос.УстановитьПараметр("Пользователь", ТекущийПользователь);
              
               РезультатЗапроса = Запрос.Выполнить().Выгрузить();
              
               Если РезультатЗапроса.Количество() = 0 Тогда
                               Возврат "";
               Иначе
                               Возврат РезультатЗапроса[0].Сообщение;
               КонецЕсли;
КонецФункции

Процедура УстановитьНовоеСообщениеДляПользователя(СообщениеДляПользователя,ТекущийПользователь) Экспорт      
               НаборЗаписей = РегистрыСведений.СообщенияПользователям.СоздатьНаборЗаписей();
               НаборЗаписей.Отбор.Пользователь.Установить(ТекущийПользователь);
              
               НовЗапись = НаборЗаписей.Добавить();
               НовЗапись.Пользователь = ТекущийПользователь;
               НовЗапись.Сообщение = СообщениеДляПользователя;
               НаборЗаписей.Записать(Истина);
КонецПроцедуры

Функция ПолучитьТекущегоПользователя() Экспорт
               Возврат Справочники.Пользователи.НайтиПоНаименованию(ПараметрыСеанса.ТекушийПользователь.Наименование,Истина);
КонецФункции
В модуле управляемого приложения
Процедура ПриНачалеРаботыСистемы()
               ПодключитьОбработчикОжидания
("ПроцедураУведомленияПользователя",180,);
КонецПроцедуры
Обработка для общения скачать.
 

CopyPaste Copyright © 2016 - |- Шаблон создан O Pregador - |- Отредактирован myr4ik07