13 янв. 2017 г.

Скрыть общедоступную папку по сети

Открыли доступ в сеть к нескольким папкам и одну из папок хотим скрыть, что бы пользователь через Проводник не смог видеть?!

Для скрытия в конце имени папки нужно поставить знак $


т.е. берем пример с windows, которая по умолчанию скрывает некие папки для отображения в общедоступных папках в сети.

13 дек. 2016 г.

Нарушена целостность структуры конфигурации при создании РИБ

При создании начального образа периферийной базы через время получаю
Нарушена целостность структуры конфигурации
В моем случаи проблема в том, что не типовые объекты (пару справочников и константа) не были добавлены в регистрацию плана обмена


После установки галки, образ успешно создался.

10 дек. 2016 г.

Медленно работает blogger

А точнее не сам блог, а админ панель, там где показывается перечень наших публикаций.


Несколько месяцев я замечал как виснет страница браузера при доволе мощном компьютере моем, когда открыта страница перечня написанных публикаций. Все лучи поноса были в сторону "гугла". И тут до меня дошло, что когда то я выбрал показ публикаций на странице в размере 100шт.


Поставил на 10-чку показ и страничка без проблем грузиться быстро.

Установить фокус на поле ввода 7.7

На форме есть элемент Поле ввода, туда вводиться штрих код товара кассиром. Задача при каждом вводе штрих кода фокус (курсор) не переносился на другой элемент формы, а оставался в Поле ввода штрих кода.

Казалось бы, все просто, ввел в процедуру или функцию вызываемую в Поле ввода на вкладке Дополнительно
Активизировать(ПолеВвода);
и все, но при тестировании у нас появилась ошибка
Активизировать(ПолеВвода,); {D:\1CTEST\1C\EXTFORMS\РАБОЧЕЕМЕСТОКАССИРА1.ERT(737)}: В данной формуле не может быть вызвана эта процедура(функция)
поэтому один умный человек порекомендовал использовать "фиктивное" закрытие формы и вот как это работает.

В модуле формы пишем
Перем ПередатьФокус;

Процедура ИзмШКТов()
 ПоискНоменклатуры(СокрЛП(ШКтов),1);
 ПередатьФокус = "ШКтов"; 
 Форма.Закрыть(0); 
КонецПроцедуры    

Процедура ПриЗакрытии()        
 Если ПустоеЗначение(ПередатьФокус) = 0 тогда 
  Активизировать(ПередатьФокус); 
  СтатусВозврата(0); 
  ПередатьФокус = ""; 
  Возврат; 
 КонецЕсли; 
КонецПроцедуры
Поясню...
Объявили глобальную переменную, по которой будет проверять в последующем, закрывается ли, так сказать, по настоящему форма или это мы "фиктивно" используем закрытие, что бы фокус передать на наше Поле ввода.
В Поле ввода на вкладке Дополнительно мы вызываем процедуру ИзмШКТов(в ней моя лабуда обработки штрих кода, а далее мы присваиваем нашей глобальной переменной имя Поле ввода (в моем случаи называется поле ввода ШКтов) и через Форма.Закрыть(0)закрываем нашу форму для того, что бы в обработчике события ПриЗакрытии(проверить, закрывается ли форма стандартным способом или фиктивно и если фиктивно тогда методом Активизировать(ПередатьФокусуже удачно, без ошибок установиться фокус (курсор) на Поле ввода. Далее делаем глобальную переменную пустой, что бы в следующий раз сделать тоже, что и выше описано, а в конце Возвратнам не дает закрыть наше фиктивное закрытие формы.
 

CopyPaste Copyright © 2017 - |- Шаблон создан O Pregador - |- Отредактирован myr4ik07