9 сент. 2016 г.

Выполнить 1С

&НаКлиенте
Функция ВыполнитьФормулуНаСервере() Экспорт 
        Перем Р;
        Формула = ""; 
        Для Каждого Ф Из ЗаписатьВМассивФормулу Цикл 
                ТекстФормулы = НайтиШаблон(Ф);
                Если ЗначениеЗаполнено(ТекстФормулы) Тогда 
                        Формула = Формула + ТекстФормулы;
                Иначе 
                        Сообщить("Формулу " + Ф + " в списке шаблонов не найдено");
                КонецЕсли;
        КонецЦикла;
       
        Выполнить("Р=" +Формула);
        Возврат Р;
КонецФункции
"Секрет" в том, что функция Выполнить() должна возвращать какое то значение, 
на то это и функция, а значит нужно определить сначала переменную куда будет 
возвращено значения выполненной команды.
 

CopyPaste Copyright © 2017 - |- Шаблон создан O Pregador - |- Отредактирован myr4ik07