9 сент. 2016 г.

Узнать дату создания объекта 1С

Функция взята с интернета.
Функция ДатаСозданияСсылки(Ссылка) Экспорт
       
        Если НЕ ЗначениеЗаполнено(Ссылка) Тогда
                Возврат Неопределено;
        КонецЕсли;     
               
        Момент = Дата(1, 1, 1);
        Попытка
               
        УИ = Строка(Ссылка.УникальныйИдентификатор());
        УИ = ВРег(СтрЗаменить(УИ,"-",""));
               
                Если Сред(УИ, 13, 1) = "1" Тогда
                       
            Значение16 = ВРег(Сред(УИ, 14, 3) + Сред(УИ, 9, 4) + Сред(УИ, 1, 8));
            Цифры16    = "123456789ABCDEF";
            Значение10 = 0;
            Длина16    = СтрДлина(Значение16);
                       
                        Для Ном = 1 По Длина16 Цикл
                Значение10 = Значение10 + Pow(16, Длина16-Ном)*Найти(Цифры16, Сред(Значение16, Ном, 1));
                        КонецЦикла;
                       
            Значение10 = Значение10/10000000;
            Момент     = Дата(1582, 10, 15, 3, 0, 0) + Значение10;
                       
                КонецЕсли;
               
    Исключение
    КонецПопытки;
       
        Возврат Момент;
               
КонецФункции
 

CopyPaste Copyright © 2017 - |- Шаблон создан O Pregador - |- Отредактирован myr4ik07