19 сент. 2016 г.

Из Com объекта в таблицу значений

На вход передаем Com объект, на выходе будем иметь ТаблицуЗначений с наименованием колонок аналогично свойствам Com объекта + заполнена ТаблицаЗначений данными с Com объекта.
Функция ИзComВТаблицуЗначений(Com)
 //Перемещаем указатель на первую запись.
 Com.MoveFirst(); 
 
 Таблица = Новый ТаблицаЗначений; 
 ОдинРаз = Неопределено;
 
 //Начинаем перебор записей из субд
 Пока Com.EOF() = 0 Цикл
  
  //Заполним колонки
  Если ОдинРаз = Неопределено Тогда 
   Для Каждого Значение Из Com.Fields Цикл 
    Таблица.Колонки.Добавить(Значение.Name);
   КонецЦикла; 
   ОдинРаз = Истина;
  КонецЕсли;
  
  //Заполняем таблицу значений
  НовСтрока = Таблица.Добавить();
  Для Каждого Колонка Из Таблица.Колонки Цикл 
   Для Каждого Значение Из Com.Fields Цикл 
    Если Колонка.Имя = Значение.Name Тогда 
     НовСтрока[Колонка.Имя] = Значение.Value;
    КонецЕсли;    
   КонецЦикла;
  КонецЦикла;
  
  // Перемещаем указатель.
  Com.MoveNext();    
 КонецЦикла;    
 Возврат Таблица
КонецФункции
 

CopyPaste Copyright © 2017 - |- Шаблон создан O Pregador - |- Отредактирован myr4ik07