19 сент. 2016 г.

Очистка таблицы значений от ненужных строк

//Очистка ТЗ от ненужных строк, алгоритм Эльниньо

 ТЗ.ВыбратьСтроки();
 Пока ТЗ.ПолучитьСтроку() = 1 Цикл 
  
     Пока ТЗ.ЧтоТо = Ненужное Цикл
          ТЗ.УдалитьСтроку();
          Если ТЗ.НомерСтроки = 0 Тогда Прервать; КонецЕсли;
  КонецЦикла;

 КонецЦикла;
 

CopyPaste Copyright © 2017 - |- Шаблон создан O Pregador - |- Отредактирован myr4ik07