15 окт. 2016 г.

Вывести диаграмму в две колонки 1С

Например, нужно вывести две диаграммы горизонтально.
Процедура Сформировать() 

 Результат.Очистить(); // Результат - это реквизит управляемой формы с типом ТабличныйДокумент
 Макет = РеквизитФормыВЗначение("Объект").ПолучитьМакет("Макет"); 
 
 Д1Макет = Д1(Макет); // в этой функции на выход будет ТабличныйДокумент с нарисованной первой диаграммой

 Д2Макет = Д2(Макет); // в этой функции на выход будет ТабличныйДокумент с нарисованной второй диаграммой
  
 Результат.Вывести(Д1Макет); 
 Результат.Присоединить(Д2Макет); 

КонецПроцедуры


Функция Д1(Макет)
    
    График = Макет.ПолучитьОбласть("Д1|Д1Г");
    
КонецФункции

Функция Д2(Макет)
    
    График = Макет.ПолучитьОбласть("Д2|Д2Г");

КонецФункции
Вся соль в том, что в макете, который мы получаем программно, а с макета области, где расположены "рисунки" диаграммы мы задаем имя не только горизонтальной области, а и вертикальной

и как раз при получении области мы указываем не только горизонтальную, а и вертикальную область
Макет.ПолучитьОбласть("Д2|Д2Г"); 
в итоге

 

CopyPaste Copyright © 2017 - |- Шаблон создан O Pregador - |- Отредактирован myr4ik07