13 июн. 2016 г.

Не срабатывает внешнее событие 1С

Пустая конфигурация (Управляемые формы), создаю внешнюю обработку, хочу, что бы при считывании Считывателем магнтных карт (СМК) данные попадали в форму, но, при остановке события на процедуре Формы ВнешнееСобытие() остановка не происходит.
Толстый клиент Управляемое приложение

&НаКлиенте        
Перем ДемоКомп;

&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
        Сообщить(Данные);
КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
        DevId = Неопределено;
        ПодключитьВнешнююКомпоненту("C:\ZR1C.dll", "Comp", ТипВнешнейКомпоненты.Native);
        ДемоКомп  = Новый("AddIn.Comp.ZR1CExtension");
        ДемоКомп.Порт = "Com3";                 
        ДемоКомп.Подключить(DevId);     
КонецПроцедуры
Толстый клиент Обычное приложение
//Создаем Реквизит объекта с типом Произвольный
Процедура КнопкаВыполнитьНажатие(Кнопка)
  DevId = Неопределено;
  ПодключитьВнешнююКомпоненту("C:\ZR1C.dll", "Comp", ТипВнешнейКомпоненты.Native);
 Реквизит1  = Новый("AddIn.Comp.ZR1CExtension");
        Реквизит1.Порт = "Com3";                        
        Реквизит1.Подключить(DevId);    
КонецПроцедуры

Процедура ВнешнееСобытие(Источник, Событие, Данные)
   Сообщить(Данные);
КонецПроцедуры
Выше был вариант подключения считывателя магнтных карт для самописной конфигурации, а вот ниже для этой же самописной конфигурации код подключения сканера штрих кода используя .dll компоненту от АТОЛ.
&НаКлиенте        
Перем ДемоКомп;

&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
 Сообщить(Данные);
КонецПроцедуры


&НаКлиенте
Процедура Команда1(Команда)
 Попытка
  ЗагрузитьВнешнююКомпоненту( "C:\Scaner1C.dll");  
  ДемоКомп = Новый("AddIn.Scaner45");
 Исключение
  Сообщить(ОписаниеОшибки());
 КонецПопытки;
КонецПроцедуры
 

CopyPaste Copyright © 2017 - |- Шаблон создан O Pregador - |- Отредактирован myr4ik07