24 дек. 2014 г.

Получить права Текущего пользователя 1С

Банально, но, если нужно узнать, какие Права доступа применены Текущему пользователю в 1С нужно создать Экспортную Процедуру в Общему модуле, в которого в Свойствах стоят галки Сервер и Вызов сервера

Процедура ПолучитьТекущиеПрава () Экспорт
Роль = РольДоступна(«Кассир»);
КонецПроцедуры

А дальше в том Модуле где нужно проверить доступность Текущему пользователю прав «Кассир» делаем вызов на Истину

Процедура ПриОткрытии ()
Если ОбщийМодульГдеПомещенаПроцедураПроверки.ПолучитьТекущиеПрава() Тогда
…. Код

Например закрыть возможность редактировать форму

Форма =  ЭтотОбьект.ПолучитьФорму(«Форма»);                             
Форма.ТолькоПросмотр = Истина;
КонецЕсли
КонецПроцедуры

 

CopyPaste Copyright © 2017 - |- Шаблон создан O Pregador - |- Отредактирован myr4ik07