7 февр. 2021 г.

Удалить спецсимволы

 Для удаления спецсимволов используем два подхода:

1.
Функция УбратьЛишниеСимволы(Строка1) Экспорт
    НовСтрока = "";
    ПравильныеСимволы = "QWERTYUIOPASDFGHJKLZXCVBNMqwertyuiopasdfghjklzxcvbnmЙЦУКЕНГШЩЗХЪФЫВАПРОЛДЖЭЯЧСМИТЬБЮйцукенгшщзхъфывапролджэячсмитьбю";
    Для Сч = 1 по СтрДлина(Строка1) Цикл
        ТекСимв = Сред(Строка1, Сч, 1);
        Если Найти(ПравильныеСимволы, ТекСимв) > 0 Тогда
            НовСтрока = НовСтрока + ТекСимв;
        КонецЕсли;
    КонецЦикла;
    
    Возврат НовСтрока;
    
КонецФункции   

2.
Функция УбратьЛишниеСимволы(Строка1)
    
    мСпецСимволов = Новый Массив;
    мСпецСимволов.Добавить(",");
    мСпецСимволов.Добавить(".");
    мСпецСимволов.Добавить("\");
    мСпецСимволов.Добавить("=");
    мСпецСимволов.Добавить("-");
    мСпецСимволов.Добавить("_");
    мСпецСимволов.Добавить("/");
    мСпецСимволов.Добавить("!");
    мСпецСимволов.Добавить("@");
    мСпецСимволов.Добавить("#");
    мСпецСимволов.Добавить("$");
    мСпецСимволов.Добавить("%");
    мСпецСимволов.Добавить("^");
    мСпецСимволов.Добавить("&");
    мСпецСимволов.Добавить("""");
    мСпецСимволов.Добавить("`");
    мСпецСимволов.Добавить("'");
    мСпецСимволов.Добавить("?");
    мСпецСимволов.Добавить("*");
    мСпецСимволов.Добавить("(");
    мСпецСимволов.Добавить(")");
    мСпецСимволов.Добавить("№");
    мСпецСимволов.Добавить(";");
    мСпецСимволов.Добавить("%");
    мСпецСимволов.Добавить("");
        
    Для Каждого СпецСимвол Из мСпецСимволов Цикл 
        Строка1 = СтрЗаменить(Строка1, СпецСимвол, " ");
    КонецЦикла;
        
    Возврат Строка1;
    
КонецФункции   


Комментариев нет:

Отправить комментарий

 

CopyPaste Copyright © 2017 - |- Шаблон создан O Pregador - |- Отредактирован myr4ik07